summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristopher Davis <christopherdavis@gnome.org>2022-12-25 16:54:50 -0600
committerFelipe Borges <felipeborges@gnome.org>2023-04-11 12:23:16 +0000
commitd25c0e345d125150cc43bf51f3b4ae526e303842 (patch)
tree9c82fee6d2dcad0e0d2cce3ef58edd228a044c0c /meson.build
parent4702757b935c60bc7d429e0309026cd19f1b6d5d (diff)
downloadgnome-control-center-d25c0e345d125150cc43bf51f3b4ae526e303842.tar.gz
general: Use AdwBanner in CcPermissionInfobar
AdwBanner is a new adaptive widget that replaces GtkInfoBar. AdwBanner adapts better to mobile sizes and has an API that fits with how we use infobars. This commit changes CcPermissionInfobar to use an AdwBanner internally instead of a GtkInfoBar. It also re-implements part of GtkLockButton, as AdwBanner does not support adding arbitrary widgets.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4251f6e73..0514e7d42 100644
--- a/meson.build
+++ b/meson.build
@@ -132,7 +132,7 @@ gtk_dep = dependency(
libadwaita_dep = dependency(
'libadwaita-1',
- version: '>= 1.2.alpha',
+ version: '>= 1.3.alpha',
fallback: ['libadwaita', 'libadwaita_dep'],
default_options: ['examples=false', 'introspection=disabled', 'tests=false', 'vapi=false'],
)