summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2022-02-24 10:14:05 +0100
committerBastien Nocera <hadess@hadess.net>2022-02-24 10:14:05 +0100
commitcbdb489fc4c11d8b3471cb57c2d036b5d53629b8 (patch)
tree836f9cec9d4a9e70b7626cd13916efcfa501ef48 /meson.build
parentd75b46b71b327dffb5ba9d4d2d74aa39743711f0 (diff)
downloadgnome-control-center-cbdb489fc4c11d8b3471cb57c2d036b5d53629b8.tar.gz
build: Check run_command() return value
As recommended by newer versions of meson: WARNING: You should add the boolean check kwarg to the run_command call. It currently defaults to false, but it will default to true in future releases of meson. See also: https://github.com/mesonbuild/meson/issues/9300
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b8b450046..d963651f9 100644
--- a/meson.build
+++ b/meson.build
@@ -146,7 +146,7 @@ polkit_gobject_dep = dependency('polkit-gobject-1', version: '>= 0.103')
# https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/491
polkit_files = [ 'gettext/its/polkit.its', 'gettext/its/polkit.loc' ]
foreach polkit_file: polkit_files
- r = run_command('build-aux/meson/find_xdg_file.py', polkit_file)
+ r = run_command('build-aux/meson/find_xdg_file.py', polkit_file, check: true)
assert(r.returncode() == 0, 'ITS support missing from polkit, please upgrade or contact your distribution')
endforeach