summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@gnome.org>2021-03-09 14:51:54 -0600
committerRobert Ancell <robert.ancell@gmail.com>2022-05-10 23:16:40 +0000
commit69f51bdab0c676d47632802c90babaf2c32b3981 (patch)
tree011088fc309b1e575db728e01e6448ed512eca0a /meson.build
parent88f87de7480f6513bcbaf658c272a9751b8f76ad (diff)
downloadgnome-control-center-69f51bdab0c676d47632802c90babaf2c32b3981.tar.gz
info-overview: add build option to control distributor logo
Currently, we display a 256x256 version of the OS icon from /etc/os-release. This is too big for my taste, and it's also not sufficient for distros that want to display a logo that is not an icon. For instance, because we no longer display the operating system name immediately beneath the logo, it may be desirable to use a logo variant that includes text. This patch adds a meson build option that distributions can use to override the logo, and a second build option to specify a different logo for use in dark mode.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 59982b4e2..2d661658f 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,17 @@ foreach define: set_defines
config_h.set_quoted(define[0], define[1])
endforeach
+distributor_logo = get_option('distributor_logo')
+if (distributor_logo != '')
+ config_h.set_quoted('DISTRIBUTOR_LOGO', distributor_logo,
+ description: 'Define to absolute path of distributor logo')
+ dark_mode_distributor_logo = get_option('dark_mode_distributor_logo')
+ if (dark_mode_distributor_logo != '')
+ config_h.set_quoted('DARK_MODE_DISTRIBUTOR_LOGO', dark_mode_distributor_logo,
+ description: 'Define to absolute path of distributor logo for use in dark mode')
+ endif
+endif
+
# meson does not support octal values, so it must be handled as a
# string. See: https://github.com/mesonbuild/meson/issues/2047
config_h.set('USER_DIR_MODE', '0700',