summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-10-18 11:32:24 -0300
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-12-14 22:34:21 -0300
commit5303a977b1a6ae1c0c484a51bd32187724705756 (patch)
treefb0f9f0a95fbd6f4bc697529669ae574017276df /meson.build
parentf41ab920b3411205984f046365ac52d97eb086e7 (diff)
downloadgnome-control-center-5303a977b1a6ae1c0c484a51bd32187724705756.tar.gz
Switch to GTK4 & libadwaita
Nothing builds now.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 8 insertions, 17 deletions
diff --git a/meson.build b/meson.build
index e9b2d7345..3815be78f 100644
--- a/meson.build
+++ b/meson.build
@@ -99,24 +99,15 @@ libgvc = subproject(
)
libgvc_dep = libgvc.get_variable('libgvc_dep')
-libhandy_dep = dependency('libhandy-1', version: '>= 1.2.0', required: false)
-if not libhandy_dep.found()
- libhandy = subproject(
- 'libhandy',
- default_options: [
- 'examples=false',
- 'glade_catalog=disabled',
- 'introspection=disabled',
- 'tests=false',
- 'vapi=false',
- ]
- )
- libhandy_dep = libhandy.get_variable('libhandy_dep')
-endif
-
goa_req_version = '>= 3.25.3'
pulse_req_version = '>= 2.0'
+libadwaita_dep = dependency(
+ 'libadwaita-1',
+ fallback: ['libadwaita', 'libadwaita_dep'],
+ default_options: ['examples=false', 'introspection=disabled', 'tests=false', 'vapi=false'],
+)
+
accounts_dep = dependency('accountsservice', version: '>= 0.6.39')
colord_dep = dependency('colord', version: '>= 0.1.34')
gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0', version: '>= 2.23.0')
@@ -141,10 +132,10 @@ common_deps = [
gio_dep,
glib_dep,
gsettings_desktop_dep,
- libhandy_dep,
+ libadwaita_dep,
dependency('gio-unix-2.0'),
dependency('gthread-2.0'),
- dependency('gtk+-3.0', version: '>= 3.22.20')
+ dependency('gtk4', version: '>= 4.4'),
]
polkit_gobject_dep = dependency('polkit-gobject-1', version: '>= 0.103')