summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFelipe Borges <felipeborges@gnome.org>2022-11-22 18:44:28 +0100
committerFelipe Borges <felipeborges@gnome.org>2022-11-24 14:16:47 +0100
commit142318eeded87bf98fdf2294243bbd68b51c2b59 (patch)
treefc9c4961ce0ac4e9562a3c8939d7fc8f3eb122c6 /meson.build
parent6629701885bb8d0549513c2a51d2a9641fdbc013 (diff)
downloadgnome-control-center-142318eeded87bf98fdf2294243bbd68b51c2b59.tar.gz
flatpak, shell: Make desktop file honor "Devel" app_id
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6c0c0196f..ebe789330 100644
--- a/meson.build
+++ b/meson.build
@@ -35,6 +35,13 @@ python = py.find_installation('python3')
config_h.set_quoted('TEST_NM_PYTHON', python.path())
+if get_option('profile') == 'development'
+ profile = 'Devel'
+else
+ profile = ''
+endif
+application_id = 'org.gnome.Settings@0@'.format(profile)
+
# defines
set_defines = [
# package