summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2014-02-12 13:36:53 +0100
committerBastien Nocera <hadess@hadess.net>2014-02-18 09:48:17 +0100
commitf31dbd02717801ed971d99468ea5d54178fdf4ec (patch)
treec9c955e907d61884c68e0a54494fe3a169dac66b /configure.ac
parent2e86e9e018e4b1ef5205c82b0b05363bd9e37288 (diff)
downloadgnome-control-center-f31dbd02717801ed971d99468ea5d54178fdf4ec.tar.gz
network: Fix build with NM 0.9.8.x
Team support was only added in the 0.9.9.x branch for the 0.9.10 stable release. It's not available in any releases (beta or stable ones) yet. https://bugzilla.gnome.org/show_bug.cgi?id=723769
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76ba9f5af..5c0156948 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,13 @@ if test x${have_networkmanager} = xyes; then
AC_SUBST(NM_VPN_MODULE_DIR)
fi
+# Work-around for https://bugzilla.gnome.org/show_bug.cgi?id=723769
+PKG_CHECK_MODULES(NM_UNSTABLE_CHECK, libnm-util >= 0.9.9.0, nm_unstable=yes, nm_unstable=no)
+if test x$nm_unstable = xyes; then
+ AC_DEFINE(HAVE_NM_UNSTABLE, 1, [Define to 1 if NetworkManager is available])
+fi
+AM_CONDITIONAL(HAVE_NM_UNSTABLE, [test x$nm_unstable = xyes])
+
# Check for gnome-bluetooth
PKG_CHECK_MODULES(BLUETOOTH, $COMMON_MODULES gnome-bluetooth-1.0 >= 3.11.1,
[have_bluetooth=yes], have_bluetooth=no)