summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2018-07-27 01:36:33 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2018-07-27 01:56:55 +0200
commit9fbd6798f45f93879e5b08fe885219e6340c7892 (patch)
treeac5ec0fa740db2ef13a277e96b72d480395a6871 /tests/meson.build
parentdf90f1d4ddcdc6b48dea4f5bacbc07b7d6896b75 (diff)
downloadgnome-contacts-9fbd6798f45f93879e5b08fe885219e6340c7892.tar.gz
Allow adding tests.
* Have a very basic test that calls something from Contacts.Utils, so we know that it was able to properly compile and link. * Some function access modifiers had to be changed to public, or they wouldn't be recoginzed outside of the static library. * Also make sure our CI actually runs the tests.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..ddf0cb5
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,12 @@
+test_names = [
+ 'basic-test',
+]
+
+foreach _test : test_names
+ test_bin = executable(_test,
+ '@0@.vala'.format(_test),
+ dependencies: libcontacts_dep,
+ )
+
+ test(_test, test_bin)
+endforeach