summaryrefslogtreecommitdiff
path: root/tests/core/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2022-09-06 22:09:25 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2023-03-02 07:31:29 +0000
commitd455b34b76a25b116b7fa82d4cb5fcf862546bfa (patch)
treee41be2b1469648334a4f2c581b38747fe2ddc1e6 /tests/core/meson.build
parent99af58107b2e49ad1b5a7fc91d290126fb8636ee (diff)
downloadgnome-contacts-d455b34b76a25b116b7fa82d4cb5fcf862546bfa.tar.gz
Move GVariant serialization into Chunk
Rather than building a big if-else block in the `Contacts.Io` namespace, it's much more interesting to move the GVariant serialization into the `Contacts.Chunk` objects themselves. That allows us to keep the serialization logic for a specific field in one place and makes sure we don't forget about any properties as they're not part of that big if-else block that checks on property name. This commit also make sure a lot of the functionality here is now unit tested, to make sure we're not accidentally regressing.
Diffstat (limited to 'tests/core/meson.build')
-rw-r--r--tests/core/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/core/meson.build b/tests/core/meson.build
index 4e38475..86101d1 100644
--- a/tests/core/meson.build
+++ b/tests/core/meson.build
@@ -7,6 +7,7 @@ test_names = [
'test-notes-chunk',
'test-phones-chunk',
'test-roles-chunk',
+ 'test-structured-name-chunk',
'test-urls-chunk',
]