summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2012-01-24 16:05:14 +0100
committerAlexander Larsson <alexl@redhat.com>2012-01-24 16:05:14 +0100
commitb95c9c928345fba18c1d25a2d576f0c3951a5bf2 (patch)
treed69cfe76881fa54819334a22ed791611f9b7e7e4 /src/Makefile.am
parenta4da7d1f277bfb564297ba9f7b776ab12b807d55 (diff)
downloadgnome-contacts-b95c9c928345fba18c1d25a2d576f0c3951a5bf2.tar.gz
Read app menu from resources
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 503a95a..18b1e9f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,7 +39,12 @@ vala_sources = \
main.vala \
$(NULL)
+contact-resources.c: contacts.gresource.xml app-menu.ui
+ $(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $(srcdir)/contacts.gresource.xml \
+ --target=$@ --sourcedir=$(srcdir) --c-name contacts --generate-source
+
gnome_contacts_SOURCES = \
+ contact-resources.c \
gtk-notification.c \
contacts-esd-setup.c \
$(vala_sources) \