summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2020-06-05 09:41:21 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2020-06-05 09:41:21 +0200
commitee93095f344009e2e74188790cd437248c8ce674 (patch)
treeecc2eecb198ab5dac22b399ad2ed31dbd2a66dd9 /meson.build
parent8f765d94df286c8381aa2349aaa43043f6963443 (diff)
downloadgnome-contacts-ee93095f344009e2e74188790cd437248c8ce674.tar.gz
meson: Fix compilation handy as subproject
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d396073..036f8cf 100644
--- a/meson.build
+++ b/meson.build
@@ -73,6 +73,13 @@ if not libhandy.found()
]
)
+ # We need to add this, since Vala queries the pkgconfig version on its own
+ # and will error out if that is lower then required one
+ add_project_arguments(
+ [ '--disable-since-check' ],
+ language: 'vala'
+ )
+
libhandy_vapidir = meson.build_root() / 'subprojects' / 'libhandy' / 'src'
else
libhandy_vapidir = ''