summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMaximiliano Sandoval R <msandova@gnome.org>2022-02-18 15:27:19 +0100
committerNiels De Graef <nielsdegraef@gmail.com>2022-03-07 22:10:23 +0000
commitea2c44ac271ec35600016d62b1e4b84f4d1b3672 (patch)
treef3a2f865c8717753ae61cc6d22be96b8072ecc22 /meson.build
parent37cf00c7512e363174f5fdd690665341d67d496e (diff)
downloadgnome-contacts-ea2c44ac271ec35600016d62b1e4b84f4d1b3672.tar.gz
meson: Use gnome.post_install
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index ce934e3..82373b9 100644
--- a/meson.build
+++ b/meson.build
@@ -83,9 +83,6 @@ conf.set_quoted('PROFILE', get_option('profile'))
conf.set('GOA_API_IS_SUBJECT_TO_CHANGE', true)
configure_file(output: 'config.h', configuration: conf)
-# Post-install scripts
-meson.add_install_script('build-aux/meson_post_install.py')
-
# Subfolders
subdir('data')
subdir('po')
@@ -94,3 +91,9 @@ if get_option('docs')
subdir('docs')
endif
subdir('tests')
+
+gnome.post_install(
+ gtk_update_icon_cache: true,
+ glib_compile_schemas: true,
+ update_desktop_database: true,
+)