summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdrien Plazas <kekun.plazas@laposte.net>2020-07-20 12:31:40 +0200
committerAdrien Plazas <kekun.plazas@laposte.net>2020-07-23 14:26:06 +0200
commite24d94f90f246d848bd5e13d876eb16128344451 (patch)
treea9718eb62eefcbc3e7d8018ab997231af81ad494 /meson.build
parente0d5147c2470ddc53737ac216477e68a1c76cd81 (diff)
downloadgnome-contacts-e24d94f90f246d848bd5e13d876eb16128344451.tar.gz
meson: Unconditionaly disable "since" checks in Vala
This is needed because the current development libhandy version is smaller than its API version. It can be dropped completely as soon as we depend on libandy 1.0.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 3 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 1f46321..ffc0838 100644
--- a/meson.build
+++ b/meson.build
@@ -10,6 +10,9 @@ i18n = import('i18n')
# Add our custom VAPI dir
add_project_arguments(
['--vapidir', meson.source_root() / 'vapi'],
+ # We need to add this, since Vala queries the pkgconfig version on its own
+ # and will error out if that is lower then required one
+ '--disable-since-check',
language: 'vala'
)
@@ -81,13 +84,6 @@ if not libhandy.found()
]
)
- # We need to add this, since Vala queries the pkgconfig version on its own
- # and will error out if that is lower then required one
- add_project_arguments(
- [ '--disable-since-check' ],
- language: 'vala'
- )
-
libhandy_vapidir = meson.build_root() / 'subprojects' / 'libhandy' / 'src'
else
libhandy_vapidir = ''