summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2020-06-07 09:53:00 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2020-06-07 09:53:00 +0200
commitb007812ab2257ed133c4bc4861288ec23f5b89cb (patch)
tree705038893c750af1e2eb3f21c97974e5a66e53bd /meson.build
parent3c081488f97aa3ee9f06ee0a42c8be382a5d485f (diff)
downloadgnome-contacts-b007812ab2257ed133c4bc4861288ec23f5b89cb.tar.gz
meson: Require Vala > 0.40.10
@ricotz helpfully pointed out that we don't need the `--disable-since-check`, since we don't even compile on valac 0.38.10. Let's remove the check for the option, and instead have a check at the beginning that people aren't trying to compile Contcts on a too old Vala.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 11 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 9005484..c69deeb 100644
--- a/meson.build
+++ b/meson.build
@@ -32,6 +32,13 @@ min_eds_version = '3.13.90'
min_folks_version = '0.11.4'
min_glib_version = '2.44' # We also use this value for --target-glib, so scratch the micro version.
+# We know that compiling on a lower version doesn't work
+min_vala_version = '0.40.10'
+if valac.version().version_compare('<' + min_vala_version)
+ error('Your Vala installation is too old (@0@).'.format(valac.version())
+ + ' Please make sure you have at least Vala ' + min_vala_version)
+endif
+
math = meson.get_compiler('c').find_library('m')
folks = dependency('folks', version: '>=' + min_folks_version)
@@ -76,12 +83,10 @@ if not libhandy.found()
# We need to add this, since Vala queries the pkgconfig version on its own
# and will error out if that is lower then required one
- if valac.version().version_compare('>= 0.31.1')
- add_project_arguments(
- [ '--disable-since-check' ],
- language: 'vala'
- )
- endif
+ add_project_arguments(
+ [ '--disable-since-check' ],
+ language: 'vala'
+ )
libhandy_vapidir = meson.build_root() / 'subprojects' / 'libhandy' / 'src'
else