summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDominique Leuenberger <dimstar@opensuse.org>2017-08-17 14:28:53 +0200
committerJeremy Bicha <jbicha@ubuntu.com>2018-02-26 22:39:58 -0500
commit2b4aca11cddf82d9c167c6ab6d620101447e88db (patch)
tree60ffd33d6cdc1bba360c8b0ca0841a596dd85c2f /meson.build
parent0ace4179f5e2b1484a747a15926ef18b093067ec (diff)
downloadgnome-color-manager-2b4aca11cddf82d9c167c6ab6d620101447e88db.tar.gz
build: Do not hardcode installation paths
https://bugzilla.gnome.org/show_bug.cgi?id=786424
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 12 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index c1773ab..3858b23 100644
--- a/meson.build
+++ b/meson.build
@@ -80,6 +80,13 @@ add_global_link_arguments(
language: 'c'
)
+prefixed_bindir = join_paths(get_option('prefix'), get_option('bindir'))
+prefixed_localedir = join_paths(get_option('prefix'), get_option('localedir'))
+prefixed_libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'))
+prefixed_mandir = join_paths(get_option('prefix'), get_option('mandir'))
+prefixed_datadir = join_paths(get_option('prefix'), get_option('datadir'))
+prefixed_pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'gnome-color-manager')
+
libgio = dependency('gio-2.0', version : '>= 2.25.9')
libgtk = dependency('gtk+-3.0', version : '>= 2.91.0')
libexif = dependency('libexif')
@@ -109,22 +116,11 @@ gnome = import('gnome')
i18n = import('i18n')
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
-conf.set_quoted('LOCALEDIR',
- join_paths(get_option('prefix'),
- get_option('localedir')))
-conf.set_quoted('DATADIR',
- join_paths(get_option('prefix'),
- get_option('datadir')))
-conf.set_quoted('PKGDATADIR',
- join_paths(get_option('prefix'),
- get_option('datadir'),
- 'gnome-color-manager'))
-conf.set_quoted('BINDIR',
- join_paths(get_option('prefix'),
- get_option('bindir')))
-conf.set_quoted('LIBEXECDIR',
- join_paths(get_option('prefix'),
- get_option('libexecdir')))
+conf.set_quoted('LOCALEDIR', prefixed_localedir)
+conf.set_quoted('DATADIR', prefixed_datadir)
+conf.set_quoted('PKGDATADIR', prefixed_pkgdatadir)
+conf.set_quoted('BINDIR', prefixed_bindir)
+conf.set_quoted('LIBEXECDIR', prefixed_libexecdir)
configure_file(
output : 'config.h',
configuration : conf