summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBobby Rong <rjl931189261@126.com>2022-02-17 22:37:28 +0800
committerBobby Rong <rjl931189261@126.com>2022-02-17 22:44:13 +0800
commitb7e84c432664f76f10680c04781ab5c3cafdd247 (patch)
tree4afee654303b4200c3682451712835fcacacfc6f /meson.build
parentd979e8e930aba81732269ac7b01e09615797825b (diff)
downloadgnome-calendar-b7e84c432664f76f10680c04781ab5c3cafdd247.tar.gz
build: Use gnome.post_install
Also requires meson 0.57.0. Otherwise the post install script will fail if GTK 3 is not installed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d26e3116..8da3cf2b 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
'c',
version: '42.rc',
license: 'GPL3+',
- meson_version: '>= 0.53.0'
+ meson_version: '>= 0.57.0'
)
@@ -187,7 +187,6 @@ src_dir = join_paths(meson.source_root(), 'src')
# Subdirs #
###########
-subdir('build-aux')
subdir('data')
subdir('src')
subdir('po')
@@ -206,3 +205,13 @@ summary({
'Debug': calendar_debug,
'Tracing': enable_tracing,
}, section: 'Development')
+
+
+###########
+# Scripts #
+###########
+
+gnome.post_install(
+ glib_compile_schemas: true,
+ gtk_update_icon_cache: true,
+)