summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-12 10:51:48 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2018-01-22 08:06:16 +0100
commit66b113ac83d204de44b4d3ee01a34d464c2cbc94 (patch)
tree0c80115208219ca364102facbf804180e28248fe /meson.build
parent1a246116ea5d519b1c8711447e16a87d620673dc (diff)
downloadgnome-calendar-66b113ac83d204de44b4d3ee01a34d464c2cbc94.tar.gz
project: Rename build options
Following the new meson porting guidelines, this patch renames the build options. The list of changes is as follows: - Remove the enable prefix from boolean options. - The character separator from multi-word options has been changed to underscore. https://bugzilla.gnome.org/show_bug.cgi?id=790234
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 276be940..9b1aa15c 100644
--- a/meson.build
+++ b/meson.build
@@ -36,8 +36,8 @@ calendar_schemadir = join_paths(calendar_datadir, 'glib-2.0', 'schemas')
calendar_buildtype = get_option('buildtype')
calendar_debug = calendar_minor_version.is_odd() or buildtype.contains('debug')
-enable_tracing = get_option('enable-tracing')
-enable_gtk_doc = get_option('enable-gtk-doc')
+enable_tracing = get_option('tracing')
+enable_gtk_doc = get_option('gtk_doc')
cc = meson.get_compiler('c')