summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristopher Davis <brainblasted@disroot.org>2018-11-03 20:36:37 -0400
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2019-09-30 12:04:08 -0300
commit0d6b2327e07fa978a5256589afbf87d9c3260872 (patch)
tree371548eba3068de4af7c06bd7a4b067fe816df01 /meson.build
parent151c47a8b3f616d1c89abd8d9bf23bd45659d10d (diff)
downloadgnome-calendar-0d6b2327e07fa978a5256589afbf87d9c3260872.tar.gz
flatpak: Allow dual installation of app bundles
Part of https://gitlab.gnome.org/GNOME/Initiatives/issues/1. Allows for the installation of development bundles alongside stable versions. Related to https://gitlab.gnome.org/GNOME/gnome-calendar/issues/285
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 18 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index d7684a0b..77d01ad6 100644
--- a/meson.build
+++ b/meson.build
@@ -34,6 +34,18 @@ calendar_schemadir = join_paths(calendar_datadir, 'glib-2.0', 'schemas')
# Options #
###########
+rev_txt = run_command('git','rev-parse','--short','HEAD').stdout().strip()
+if get_option('profile') == 'development'
+ profile = 'Devel'
+ name_suffix = ' (Development)'
+ rev = '-@0@'.format(rev_txt)
+else
+ profile = ''
+ name_suffix = ''
+ rev = ''
+endif
+
+application_id = 'org.gnome.Calendar.@0@'.format(profile)
calendar_buildtype = get_option('buildtype')
calendar_debug = calendar_minor_version.is_odd() or calendar_buildtype.contains('debug')
enable_tracing = get_option('tracing')
@@ -52,9 +64,12 @@ set_defines = [
['PACKAGE_STRING', '@0@ @1@'.format(meson.project_name(), calendar_version)],
['PACKAGE_TARNAME', meson.project_name()],
['PACKAGE_URL', 'https://wiki.gnome.org/Apps/Calendar'],
- ['PACKAGE_VERSION', calendar_version],
- ['VERSION', calendar_version],
- ['GETTEXT_PACKAGE', meson.project_name()]
+ ['PACKAGE_VERSION', calendar_version + rev],
+ ['VERSION', calendar_version + rev],
+ ['GETTEXT_PACKAGE', meson.project_name()],
+ ['PROFILE', profile],
+ ['NAME_SUFFIX', name_suffix],
+ ['APPLICATION_ID', application_id]
]
foreach define: set_defines