summaryrefslogtreecommitdiff
path: root/sendto/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-08-02 18:03:26 +0200
committerIñigo Martínez <inigomartinez@gmail.com>2017-08-12 22:08:14 +0200
commite8ad2adfebd6821b459f1d6ba6a8c6f243fcb482 (patch)
treecbc7cc615fe8aecebfa796b18baea8e70dc5b26a /sendto/meson.build
parent448fa6a2809f9225b5471d975a8b787a16e5f41f (diff)
downloadgnome-bluetooth-e8ad2adfebd6821b459f1d6ba6a8c6f243fcb482.tar.gz
build: Migrated from Intltool to Gettext
https://bugzilla.gnome.org/show_bug.cgi?id=785742
Diffstat (limited to 'sendto/meson.build')
-rw-r--r--sendto/meson.build15
1 files changed, 8 insertions, 7 deletions
diff --git a/sendto/meson.build b/sendto/meson.build
index de65c2aa..bf4f8165 100644
--- a/sendto/meson.build
+++ b/sendto/meson.build
@@ -33,19 +33,20 @@ install_man(
desktop_conf = configuration_data()
desktop_conf.set('VERSION', gnomebt_version)
-desktop_name = name + '.desktop'
+desktop = name + '.desktop'
desktop_in = configure_file(
- input: desktop_name + '.in.in',
- output: desktop_name + '.in',
+ input: desktop + '.in.in',
+ output: desktop + '.in',
configuration: desktop_conf
)
-custom_target(
- desktop_name,
+i18n.merge_file (
+ desktop,
+ type: 'desktop',
input: desktop_in,
- output: desktop_name,
- command: [intltool_merge, '-d', '-u', '-c', intltool_cache, po_dir, '@INPUT@', '@OUTPUT@'],
+ output: desktop,
+ po_dir: po_dir,
install: true,
install_dir: join_paths(gnomebt_datadir, 'applications')
)