summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristopher Davis <christopherdavis@gnome.org>2022-01-31 12:22:01 -0800
committerBastien Nocera <hadess@hadess.net>2022-02-07 09:03:20 +0000
commite982b0f2bb0a2414cf2d50835a261387872093ff (patch)
tree799b2b546611a492e890640afd288cb596ef71e0 /meson.build
parent26fdf894e8d3534a34fca8ca4b169ffd4459115b (diff)
downloadgnome-bluetooth-e982b0f2bb0a2414cf2d50835a261387872093ff.tar.gz
meson: Add libadwaita as a subproject
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d43822d5..63a04caa 100644
--- a/meson.build
+++ b/meson.build
@@ -99,7 +99,12 @@ gio_dep = dependency('gio-2.0', version: '>= 2.44')
gio_unix_dep = dependency('gio-unix-2.0')
gtk_dep = dependency('gtk4', version: '>= 4.4')
gsound_dep = dependency('gsound')
-libadwaita_dep = dependency('libadwaita-1', version: '>= 1.1')
+libadwaita_dep = dependency(
+ 'libadwaita-1',
+ version: '>= 1.1',
+ fallback: ['libadwaita', 'libadwaita_dep'],
+ default_options: ['examples=false', 'introspection=disabled', 'tests=false', 'vapi=false'],
+)
libnotify_dep = dependency('libnotify', version: '>= 0.7.0')
libudev_dep = dependency('libudev')