summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-10-22 19:24:42 -0300
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-10-26 08:56:51 -0300
commite7c972c0289f2006cb631339466d52d7a555dcae (patch)
treeafb2859ed88637dbd388db706c3beb1b7fd85683 /meson.build
parent161a1579a84ab19a2d90186048a1f40a1a42e97e (diff)
downloadgnome-bluetooth-e7c972c0289f2006cb631339466d52d7a555dcae.tar.gz
settings: Replace canberra-gtk by to gsound
Mainly to reduce the number of GTK3 dependencies before actually start porting the library. Fortunately, the usage of libcanberra-gtk by gnome-bluetooth is rather trivial, so porting to gsound is just a few lines of code away. Replace canberra-gtk by gsound, adjust the build system to reflect that, and update the CI file to install gsound-devel instead of libcanberra-devel.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 79bf7a24..badeb896 100644
--- a/meson.build
+++ b/meson.build
@@ -100,7 +100,7 @@ add_project_arguments(common_flags + compiler_flags, language: 'c')
gio_dep = dependency('gio-2.0', version: '>= 2.44')
gio_unix_dep = dependency('gio-unix-2.0')
gtk_dep = dependency('gtk+-3.0', version: '>= 3.12.0')
-libcanberra_gtk_dep = dependency('libcanberra-gtk3')
+gsound_dep = dependency('gsound')
libnotify_dep = dependency('libnotify', version: '>= 0.7.0')
libudev_dep = dependency('libudev')