summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-10-26 21:03:12 -0300
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-10-28 11:16:33 -0300
commitd2d44a68b5fb2c7a66c5f1197f119a01d4e5b32e (patch)
tree4780a34a32b1182443f92e532334d81fbad22b9f /meson.build
parentee56d8cce5981e2ca39d525a4c5907d9c492fc6d (diff)
downloadgnome-bluetooth-d2d44a68b5fb2c7a66c5f1197f119a01d4e5b32e.tar.gz
build: Bump API version
We're about to break the public API due to the GTK4 transition so preemptively bump the API version. However, given that GNOME Shell uses gnome-bluetooth (and has other GTK3 dependencies), making gnome-bluetooth-2.0 parallel installable is our only option. Bump the API version, and make gnome-bluetooth-2.0 parallel installable with 1.0. Do that by using the 'gnomebt_api_name' meson variable, which contains meson.project_name() + API version, as the library name and install location.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index badeb896..536acc29 100644
--- a/meson.build
+++ b/meson.build
@@ -12,7 +12,7 @@ gnomebt_major_version = version_array[0].to_int()
gnomebt_minor_version = version_array[1].to_int()
gnomebt_micro_version = version_array[2].to_int()
-gnomebt_api_version = '1.0'
+gnomebt_api_version = '2.0'
gnomebt_api_name = '@0@-@1@'.format(meson.project_name(), gnomebt_api_version)
gnomebt_gir_ns = 'GnomeBluetooth'