summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2022-01-18 17:54:10 +0100
committerBastien Nocera <hadess@hadess.net>2022-01-19 12:21:13 +0100
commitcbc08c4f293664e681b1646e794e7cf62782c6cc (patch)
treef51339cc4229e93f2e4bd3f01b54f1ca4c960601 /meson.build
parent1604c5739a59cf0fcf24e6814a4db68356db9b62 (diff)
downloadgnome-bluetooth-cbc08c4f293664e681b1646e794e7cf62782c6cc.tar.gz
lib: Split UI and non-UI libraries
Both UI and non-UI libraries export a pkg-config file. Only the non-UI library exports a Gir as it's the only one that gets to be used from a non-native program (gnome-shell).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1b27f533..895c5070 100644
--- a/meson.build
+++ b/meson.build
@@ -12,6 +12,7 @@ gnomebt_major_version = version_array[0].to_int()
gnomebt_api_version = '3.0'
gnomebt_api_name = '@0@-@1@'.format(meson.project_name(), gnomebt_api_version)
+gnomebt_ui_api_name = '@0@-ui-@1@'.format(meson.project_name(), gnomebt_api_version)
gnomebt_gettext_package = gnomebt_api_name
gnomebt_gir_ns = 'GnomeBluetooth'