summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdrien Plazas <kekun.plazas@laposte.net>2018-09-20 17:28:15 +0200
committerAdrien Plazas <kekun.plazas@laposte.net>2019-01-29 12:35:00 +0100
commitb2385d7d0a1477c94e1f364e24386c71d1715228 (patch)
treeb4555b0da840b526a936ff41d73dcc76d52091df /meson.build
parent0b17bb166823cc53546c4010efd53e3760cdfaca (diff)
downloadgnome-bluetooth-b2385d7d0a1477c94e1f364e24386c71d1715228.tar.gz
meson: Add the libhandy 0.0.7 subproject
This will be needed by the next commit to access HdyColumn. This also lets the CI recursively update the submodules so it can pass.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ed6dc268..0fa969ab 100644
--- a/meson.build
+++ b/meson.build
@@ -100,6 +100,18 @@ gio_dep = dependency('gio-2.0')
gio_unix_dep = dependency('gio-unix-2.0')
gtk_dep = dependency('gtk+-3.0', version: '>= 3.12.0')
libcanberra_gtk_dep = dependency('libcanberra-gtk3')
+libhandy = subproject(
+ 'libhandy',
+ default_options: [
+ 'examples=false',
+ 'glade_catalog=disabled',
+ 'introspection=disabled',
+ 'static=true',
+ 'tests=false',
+ 'vapi=false',
+ ]
+)
+libhandy_dep = libhandy.get_variable('libhandy_dep')
libnotify_dep = dependency('libnotify', version: '>= 0.7.0')
libudev_dep = dependency('libudev')