summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2022-01-24 10:38:35 +0100
committerBastien Nocera <hadess@hadess.net>2022-02-07 10:21:35 +0100
commit983838f126131a8b017e14f1d493e04767f5f654 (patch)
tree230e9d398da67c2ef401330d66e65e2674a2463a /meson.build
parentbab9c8f463814ef818dea4380b0df7e0762f3fbc (diff)
downloadgnome-bluetooth-983838f126131a8b017e14f1d493e04767f5f654.tar.gz
lib: Add battery reporting through BluetoothDevice
Connect and monitor UPower devices for devices reporting their battery status. This makes sure that we can show battery status for devices that emit their battery status through bluez (via the BATT LE service, or the org.bluez.BatteryProviderManager1 API, as well as devices for which the kernel is the battery info provider. Closes: #102
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 04a1491e..9a3bec6f 100644
--- a/meson.build
+++ b/meson.build
@@ -107,7 +107,7 @@ libadwaita_dep = dependency(
)
libnotify_dep = dependency('libnotify', version: '>= 0.7.0')
libudev_dep = dependency('libudev')
-upower_dep = dependency('upower-glib')
+upower_dep = dependency('upower-glib', version: '>= 0.99.14')
m_dep = cc.find_library('m')