summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2022-01-20 13:53:47 +0100
committerBastien Nocera <hadess@hadess.net>2022-01-20 13:53:47 +0100
commit020c56c5220a89093b0f3742568605602f268108 (patch)
tree6fddb81723f6dd0dc790421e7368b1573d3e9be4 /meson.build
parentc3d49d2d4a24e9daf931370d24413f857985b087 (diff)
downloadgnome-bluetooth-020c56c5220a89093b0f3742568605602f268108.tar.gz
build: Add a check for python-dbusmock
We'll need it before meson configures itself soon.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9a4092b4..6bead6d0 100644
--- a/meson.build
+++ b/meson.build
@@ -115,6 +115,15 @@ if enable_gtk_doc
endif
subdir('po')
+
+python = import('python')
+python3 = python.find_installation('python3')
+has_dbusmock = false
+script = 'import dbusmock'
+if run_command(python3, '-c', script, check: false).returncode() == 0
+ has_dbusmock = true
+endif
+
subdir('tests')
configure_file(
@@ -130,6 +139,7 @@ meson.add_install_script(
summary({'Documentation': enable_gtk_doc,
'Introspection': enable_gir,
+ 'Dbusmock tests': has_dbusmock,
'Send-to': get_option('sendto'),
'Run gtk-update-icon-cache': get_option('icon_update')},
section: 'General')