summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-03-23 12:55:31 +0100
committerBastien Nocera <hadess@hadess.net>2021-03-23 14:23:25 +0100
commit020a752a9e7107c61f25316623d775962fbc0157 (patch)
treecaca4ac44702338cacb9c44772aba3cc4568cb3b /meson.build
parent9c3d75dfd33e8b8d91b3bcf709567182f74ae053 (diff)
downloadgnome-bluetooth-020a752a9e7107c61f25316623d775962fbc0157.tar.gz
build: Fix soname creation to match libtool versioning
The documentation we brought forward from autotools/libtool didn't actually match sonames, but used libtool rules. Replicate the libtool rules to fix the unwanted soname bump. Closes: #82
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e59e3a35..6df6396b 100644
--- a/meson.build
+++ b/meson.build
@@ -40,7 +40,8 @@ current = 14
revision = 0
age = 1
-libversion = '@0@.@1@.@2@'.format(current, age, revision)
+lt_soversion = current - age
+libversion = '@0@.@1@.@2@'.format(lt_soversion, age, revision)
gnome = import('gnome')
i18n = import('i18n')