summaryrefslogtreecommitdiff
path: root/tls/openssl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tls/openssl/meson.build')
-rw-r--r--tls/openssl/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/tls/openssl/meson.build b/tls/openssl/meson.build
index b1adab7..bc1aedb 100644
--- a/tls/openssl/meson.build
+++ b/tls/openssl/meson.build
@@ -43,11 +43,11 @@ module = shared_module(
link_args: module_ldflags,
link_depends: symbol_map,
name_suffix: module_suffix,
- install: true,
+ install: build_shared,
install_dir: gio_module_dir,
)
-if get_option('static_modules') or get_option('default_library') != 'shared'
+if build_static
gioopenssl_lib = static_library('gioopenssl',
objects: module.extract_all_objects(recursive: true),
dependencies: deps,