summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-08-04 09:08:28 +0200
committerStef Walter <stefw@collabora.co.uk>2011-08-04 09:08:28 +0200
commite484f34fdd0d132acaedf0cbabc99708137e1293 (patch)
tree4faaa3ba3601ecf1a9be2c7764233282f5c73a3c /Makefile.am
parentdc73236fc93638ae5c262913c75a39fd2656f74e (diff)
downloadglib-networking-e484f34fdd0d132acaedf0cbabc99708137e1293.tar.gz
gnutls: Implement GTlsDatabase and related objects
The database is an abstract object implemented by the various TLS backends, which is used by GTlsConnection to lookup certificates and keys, as well as verify certificate chains. Here we implement a file based database to lookup anchor certificates for use with GnuTLS. Also hookup the various bits for GTlsInteraction, but don't actually use that yet. https://bugzilla.gnome.org/show_bug.cgi?id=636572
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c34280..41c7a60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,8 @@ if HAVE_GNUTLS
SUBDIRS += tls/gnutls
endif
+SUBDIRS += tls/tests
+
install-exec-hook:
if test -n "$(GIO_QUERYMODULES)" -a -z "$(DESTDIR)"; then \
$(GIO_QUERYMODULES) $(GIO_MODULE_DIR) ; \