summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2010-12-11 15:23:51 +0100
committerDan Winship <danw@gnome.org>2011-03-16 10:09:49 -0400
commit00c639ccb953a36ae5be3dc2bcfe87a14b9592d1 (patch)
tree9cf8738ad323b4af837397afd0bc735a852c3b80 /Makefile.am
parenteaaa73ebab6485edaa763f6d4627977ce7a97cfb (diff)
downloadglib-networking-00c639ccb953a36ae5be3dc2bcfe87a14b9592d1.tar.gz
Implement a GNOME proxy backend using GSettings
Use the network proxy settings from gsettings-desktop-schemas and return proxies based on that. For Automatic proxy configuration, we use the D-Bus service provided by the libproxy plugin. https://bugzilla.gnome.org/show_bug.cgi?id=644211
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e030c1..2c34280 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,10 @@ if HAVE_LIBPROXY
SUBDIRS += proxy/libproxy
endif
+if HAVE_GNOME_PROXY
+SUBDIRS += proxy/gnome
+endif
+
if HAVE_GNUTLS
SUBDIRS += tls/gnutls
endif