summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTom Schoonjans <Tom.Schoonjans@rfi.ac.uk>2020-05-07 09:07:43 +0100
committerTom Schoonjans <Tom.Schoonjans@rfi.ac.uk>2020-05-07 09:07:48 +0100
commitce473462ed65be1cf2d5e5478737461c927b345f (patch)
tree580bd138352d41a2c4e9689664171b665adb5f27 /meson.build
parentac5b9d45fa7eaa83cd8ed688248989b318bcde54 (diff)
downloadglade-ce473462ed65be1cf2d5e5478737461c927b345f.tar.gz
Build: use gtk-mac-integration only when creating bundle
Gtk-mac-integration was used only when creating the bundle, So there's no need to drag it as a dependency just because the build occurs on a macOS with a Gtk installation with Quartz backend.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 201f16c2..71f3f6d7 100644
--- a/meson.build
+++ b/meson.build
@@ -147,9 +147,9 @@ have_webkit2gtk = webkit2gtk_dep.found()
# Check for GDK Quartz and MacOSX integration package
enable_mac_integration = dependency('gdk-3.0').get_pkgconfig_variable('targets').contains('quartz')
if enable_mac_integration
- gtk_mac_integration_gtk3_dep = dependency('gtk-mac-integration-gtk3')
if get_option('mac_bundle')
+ gtk_mac_integration_gtk3_dep = dependency('gtk-mac-integration-gtk3')
gtk_mac_bundle_flags = '-DMAC_BUNDLE'
endif
endif