summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJuan Pablo Ugarte <juanpablougarte@gmail.com>2020-06-05 20:13:15 -0300
committerJuan Pablo Ugarte <juanpablougarte@gmail.com>2020-06-05 20:16:05 -0300
commit6f4fb5672f41201a20e0f879a7d7d7b96f045425 (patch)
tree5dc376ea4ec66ae579f5a30a930676de13689d4e /meson.build
parentba841dbcf448eb275c327d06ce972ad0ae80b640 (diff)
downloadglade-6f4fb5672f41201a20e0f879a7d7d7b96f045425.tar.gz
Python plugin: fix linking error
Since pygobject 3.8 we need to link with python-3.8-embed to avoid missing symbols when loading the plugin. Fix compiler warning
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 729e6df6..78f96809 100644
--- a/meson.build
+++ b/meson.build
@@ -138,7 +138,7 @@ pygobject_version = '3.8.0'
pygobject_dep = dependency('pygobject-3.0', version: '>= ' + pygobject_version, required: get_option('python'))
have_python = pygobject_dep.found()
if have_python
- python_dep = import('python').find_installation().dependency()
+ python_dep = dependency('python-3.8-embed', version: '>= 3.8')
version_array = pygobject_version.split('.')
config_h.set('PYGOBJECT_REQUIRED_MAJOR', version_array[0].to_int())