summaryrefslogtreecommitdiff
path: root/tools/meson.build
diff options
context:
space:
mode:
authorCorentin Noël <corentin.noel@collabora.com>2021-12-02 17:32:45 +0100
committerCorentin Noël <tintou@noel.tf>2022-04-09 00:43:08 +0200
commitcf38035ed9b881d198c0fe740bc493d30b30149c (patch)
tree9652bf7a299facbab7b25c4e5e82cf3bf87863d4 /tools/meson.build
parente2e875b500106aab85e1371298162dd084494652 (diff)
downloadgcr-cf38035ed9b881d198c0fe740bc493d30b30149c.tar.gz
tools: Move gcr-promper and gcr-viewer into their own directory
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build65
1 files changed, 65 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
new file mode 100644
index 0000000..a8d2309
--- /dev/null
+++ b/tools/meson.build
@@ -0,0 +1,65 @@
+# gcr-viewer
+gcr_viewer = executable('gcr-viewer',
+ 'gcr-viewer-tool.c',
+ 'gcr-viewer-window.c',
+ dependencies: [ gcr_gtk3_dep, gcr_gtk3_deps ],
+ c_args: gcr_gtk3_cflags,
+ include_directories: config_h_dir,
+ install: true,
+)
+
+i18n.merge_file(
+ input: configure_file(
+ input: 'gcr-viewer.desktop.in.in',
+ output: '@BASENAME@',
+ configuration: { 'bindir': gcr_prefix / get_option('bindir') },
+ ),
+ output: '@BASENAME@',
+ type: 'desktop',
+ po_dir: podir,
+ install: true,
+ install_dir: get_option('datadir') / 'applications',
+)
+
+# gcr-prompter
+gcr_prompter = executable('gcr-prompter',
+ 'gcr-prompter-tool.c',
+ dependencies: [ gcr_gtk3_dep, gcr_gtk3_deps ],
+ c_args: gcr_gtk3_cflags,
+ include_directories: config_h_dir,
+ install: true,
+ install_dir: get_option('libexecdir'),
+)
+
+i18n.merge_file(
+ input: configure_file(
+ input: 'gcr-prompter.desktop.in.in',
+ output: '@BASENAME@',
+ configuration: { 'libexecdir': gcr_prefix / get_option('libexecdir') },
+ ),
+ output: '@BASENAME@',
+ type: 'desktop',
+ po_dir: podir,
+ install: true,
+ install_dir: get_option('datadir') / 'applications',
+)
+
+
+# Manual UI testing programs
+gcr_tools_manual_tests = [
+ 'frob-unlock',
+]
+
+gcr_tools_test_cflags = [
+ '-DSRCDIR="@0@"'.format(source_root),
+]
+
+foreach _test : gcr_tools_manual_tests
+ test_bin = executable('test-'+_test,
+ '@0@.c'.format(_test),
+ 'gcr-viewer-window.c',
+ dependencies: [ gcr_gtk3_deps, gcr_gtk3_dep ],
+ c_args: [ gcr_gtk3_cflags, gcr_tools_test_cflags ],
+ include_directories: config_h_dir,
+ )
+endforeach