summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCorentin Noël <corentin.noel@collabora.com>2021-12-07 12:29:33 +0100
committerCorentin Noël <tintou@noel.tf>2022-04-09 00:44:22 +0200
commitd8c7ba55555acab2dbdeefda5b0decbb84d1d701 (patch)
treeb09109b843ed7163c36e0d76145eb91bb4706508 /meson.build
parentab94a01bbbcb90b360e1892e1e0153d1724a8028 (diff)
downloadgcr-d8c7ba55555acab2dbdeefda5b0decbb84d1d701.tar.gz
Create gcr-gtk4 library
Signed-off-by: Corentin Noël <corentin.noel@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 12 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index c6607b5..9d708b9 100644
--- a/meson.build
+++ b/meson.build
@@ -38,6 +38,7 @@ gck_basename = 'gck-@0@'.format(gck_api_version)
gcr_base_basename = 'gcr-base-@0@'.format(gcr_api_version)
gcr_basename = 'gcr-@0@'.format(gcr_api_version)
gcr_gtk3_basename = 'gcr-@0@-gtk3'.format(gcr_api_version)
+gcr_gtk4_basename = 'gcr-@0@-gtk4'.format(gcr_api_version)
# Dependencies
min_glib_version = '2.44'
@@ -72,9 +73,13 @@ if libsystemd.found() and systemd.found()
with_systemd = true
endif
-if get_option('gtk')
- gtk_min_version = '3.22'
- gtk_dep = dependency('gtk+-3.0', version: '>=' + gtk_min_version)
+if get_option('gtk3')
+ gtk3_min_version = '3.22'
+ gtk3_dep = dependency('gtk+-3.0', version: '>=' + gtk3_min_version)
+endif
+
+if get_option('gtk4')
+ gtk4_dep = dependency('gtk4')
endif
# configuration
@@ -104,9 +109,12 @@ subdir('egg')
subdir('gck')
subdir('gcr')
subdir('schema')
-if get_option('gtk')
+if get_option('gtk3')
subdir('gcr-gtk3')
endif
+if get_option('gtk4')
+ subdir('gcr-gtk4')
+endif
subdir('tools')
if get_option('gtk_doc')
if not get_option('introspection')