summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2022-06-12 23:41:12 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2022-06-13 16:57:04 +0200
commitd791344fd4bd7ce518ed2837050ed616395a45a9 (patch)
tree5b2b0c838de0cf48fea2aab5fda60d79ce6a141d /meson.build
parent1d4d7350c93461ebd2192964ef5db25edee27219 (diff)
downloadgcr-d791344fd4bd7ce518ed2837050ed616395a45a9.tar.gz
meson: Use `full_path()` instead of `path()`meson-stuff
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index e58e97e..21a02fa 100644
--- a/meson.build
+++ b/meson.build
@@ -51,7 +51,7 @@ gio_unix_dep = dependency('gio-unix-2.0',version: '>=' + min_glib_version)
glib_deps = [ glib_dep, gmodule_dep, gthread_dep, gobject_dep, gio_dep, gio_unix_dep, ]
gpg_path = get_option('gpg_path')
if gpg_path == ''
- gpg_path = find_program('gpg2', 'gpg').path()
+ gpg_path = find_program('gpg2', 'gpg').full_path()
endif
libgcrypt_dep = dependency('libgcrypt', version: '>= 1')
p11kit_dep = dependency('p11-kit-1', version: '>= 0.19.0')
@@ -60,8 +60,8 @@ if p11_system_config_modules == ''
error('Couldn\'t find location for pkcs11 module config')
endif
libsecret_dep = dependency('libsecret-1', version: '>= 0.20', required: get_option('ssh_agent'))
-ssh_add_path = find_program('ssh-add', required: get_option('ssh_agent')).path()
-ssh_agent_path = find_program('ssh-agent', required: get_option('ssh_agent')).path()
+ssh_add_path = find_program('ssh-add', required: get_option('ssh_agent')).full_path()
+ssh_agent_path = find_program('ssh-agent', required: get_option('ssh_agent')).full_path()
with_systemd = false
libsystemd_deps = []