summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2022-06-12 23:18:12 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2022-06-13 16:57:04 +0200
commit9b1e76f70ea4d27e9d0b2b27dd4d24f200aa1e80 (patch)
treecad3b774f0665d00fb7ad7d7e791efc49902f68b /meson.build
parent6a7a6fc74d8e23ff2f63a02edc0f7079197891d1 (diff)
downloadgcr-9b1e76f70ea4d27e9d0b2b27dd4d24f200aa1e80.tar.gz
meson: Use gnome.post_install()
Allows us to drop our custom post-install script, and fixes some known issues with it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e2dd727..c3d9ba3 100644
--- a/meson.build
+++ b/meson.build
@@ -131,6 +131,8 @@ if get_option('gtk_doc')
endif
# Post-install scripts
-meson.add_install_script('meson_post_install.py',
- get_option('datadir'),
+gnome.post_install(
+ gtk_update_icon_cache: true,
+ glib_compile_schemas: true,
+ update_desktop_database: true,
)