summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCorentin Noël <corentin.noel@collabora.com>2022-04-08 13:05:08 +0200
committerCorentin Noël <corentin.noel@collabora.com>2022-04-08 14:34:01 +0200
commit8bf5750edf448f113615bab1cff3bdb5ddbb5557 (patch)
tree446bbb00fc5699e6edc2b84dd841735e3db711c1 /meson.build
parent6b26cb36960fe8c627f0b1e49c07a43c31f0a3b7 (diff)
downloadgcr-8bf5750edf448f113615bab1cff3bdb5ddbb5557.tar.gz
meson: Declare libversion variables and consistently use it
Do not rely on major_version to manually create the library names. Make sure to be consistent and use a single variable for all the library names and folder mentions.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dea1b69..e2ec57c 100644
--- a/meson.build
+++ b/meson.build
@@ -9,6 +9,7 @@ i18n = import('i18n')
pkgconfig = import('pkgconfig')
# Versioning
+gcr_api_version = '3'
gcr_version = meson.project_version()
gcr_soversion = '1.0.0'
gcr_version_array = gcr_version.split('.')
@@ -16,6 +17,7 @@ gcr_major_version = gcr_version_array[0].to_int()
gcr_minor_version = gcr_version_array[1].to_int()
gcr_micro_version = gcr_version_array[2].to_int()
+gck_api_version = '1'
gck_version = '1.0.0'
gck_soversion = '0.0.0'
gck_version_array = gck_version.split('.')
@@ -32,6 +34,11 @@ gcr_prefix = get_option('prefix')
libexecbindir = gcr_prefix / get_option('libexecdir')
podir = source_root / 'po'
+gck_basename = 'gck-@0@'.format(gck_api_version)
+gcr_base_basename = 'gcr-base-@0@'.format(gcr_api_version)
+gcr_basename = 'gcr-@0@'.format(gcr_api_version)
+gcr_ui_basename = 'gcr-ui-@0@'.format(gcr_api_version)
+
# Dependencies
min_glib_version = '2.44'
glib_dep = dependency('glib-2.0', version: '>=' + min_glib_version)