summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2021-09-30 13:41:44 +0200
committerCorentin Noël <tintou@noel.tf>2021-11-10 10:51:39 +0000
commit6fc2f87a5e02558d9550a533fc0266aea5a127c0 (patch)
treefbb7ea3fabb25080e36a12738ab6504c30a34371 /meson.build
parent8617fe225a045a0eba701bdc0bf6349480720233 (diff)
downloadgcr-6fc2f87a5e02558d9550a533fc0266aea5a127c0.tar.gz
docs: Port from gtk-doc to gi-docgen
gtk-doc has been slowly dying for the past few years. With gi-docgen we have a clear successor in sight to replace the voodoo magic one needs to get the whole documentation setup. See the [gi-docgen tutorial] for more info on how the system works. Since we're now only the C compiler (and GIR) parse the C code, that means we can also get rid of all the special escapes for the # character in PKCS#11. [gi-docgen tutorial]: https://gnome.pages.gitlab.gnome.org/gi-docgen/tutorial.html
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6fa0ff4..dea1b69 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gcr', 'c',
version: '3.41.0',
- meson_version: '>= 0.49',
+ meson_version: '>= 0.52',
license: 'GPL2+',
)
@@ -101,6 +101,10 @@ if get_option('gtk')
subdir('ui')
endif
if get_option('gtk_doc')
+ if not get_option('introspection')
+ error('Can\'t generate docs without introspection enabled!')
+ endif
+
subdir('docs')
endif