summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2022-06-12 23:36:33 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2022-06-13 16:57:04 +0200
commit6c6c05d5b3f8b7ffe6137020bb702d8df670b387 (patch)
treefa66ac2d8eef0a6ff6136fb5abb9b9fa01bc98a4 /meson.build
parentc16f69a98d3cfa52eae7f650cd2adfe95f5dea87 (diff)
downloadgcr-6c6c05d5b3f8b7ffe6137020bb702d8df670b387.tar.gz
meson: add falback for systemduserunitdir prefix
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a1e0882..e94db02 100644
--- a/meson.build
+++ b/meson.build
@@ -68,7 +68,10 @@ libsystemd_deps = []
libsystemd = dependency('libsystemd', required: get_option('systemd'))
systemd = dependency('systemd', required: get_option('systemd'))
if libsystemd.found() and systemd.found()
- systemduserunitdir = systemd.get_pkgconfig_variable('systemduserunitdir')
+ systemduserunitdir = systemd.get_variable('systemduserunitdir',
+ pkgconfig_define: [ 'prefix', get_option('prefix') ],
+ default_value: 'lib' / 'systemd' / 'user',
+ )
libsystemd_deps += libsystemd
with_systemd = true
endif