summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2022-07-17 21:09:55 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2022-07-17 21:09:55 +0200
commit683c081a3ecfebc4e1ed356c81d67a5bc878c778 (patch)
treecbc98175421f8befb4e7729ec8af4413ea153487 /meson.build
parent7ea633f385545e46a329e42d535abb23991c6bd5 (diff)
downloadgcr-683c081a3ecfebc4e1ed356c81d67a5bc878c778.tar.gz
Drop Gck list API
gck provided some APIs that made working with lists of `GObject`s easier. GLib has for a long time added API that works well enough for the same use case, like `g_list_copy_deep()`, `g_list_free_full()` and more recently also `g_clear_list()`, so use those instead. This commit also bumps the required GLib version to a more modern 2.64 (which is needed for the `g_clear_list()` API).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4c2a728..1c6db2a 100644
--- a/meson.build
+++ b/meson.build
@@ -41,7 +41,7 @@ gcr_gtk3_basename = 'gcr-@0@-gtk3'.format(gcr_api_version)
gcr_gtk4_basename = 'gcr-@0@-gtk4'.format(gcr_api_version)
# Dependencies
-min_glib_version = '2.44'
+min_glib_version = '2.64'
glib_dep = dependency('glib-2.0', version: '>=' + min_glib_version)
gmodule_dep = dependency('gmodule-no-export-2.0', version: '>=' + min_glib_version)
gthread_dep = dependency('gthread-2.0', version: '>=' + min_glib_version)