summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarvin Schmidt <marv@exherbo.org>2022-02-10 12:09:12 +0100
committerMarvin Schmidt <marv@exherbo.org>2022-04-29 09:31:24 +0200
commit5970a456465b6b6a6a3f4c215e1926c3c3c3f5cb (patch)
tree25f80bcb7010c01bac498e70853c176c14f1c190 /meson.build
parent5924eced679b3a2caea2fd4637e52b85c85f6f0c (diff)
downloadgcr-5970a456465b6b6a6a3f4c215e1926c3c3c3f5cb.tar.gz
build: Make building the Vala bindings optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dd70d01..1070660 100644
--- a/meson.build
+++ b/meson.build
@@ -82,6 +82,12 @@ if get_option('gtk4')
gtk4_dep = dependency('gtk4')
endif
+enable_gir = get_option('introspection')
+enable_vapi = get_option('vapi')
+if enable_vapi
+ assert(enable_gir, 'vapi support was requested, but introspection support is mandatory.')
+endif
+
# configuration
conf = configuration_data()
conf.set_quoted('VERSION', meson.project_version())