summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2020-01-06 20:11:36 +0100
committerDaiki Ueno <ueno@gnu.org>2020-01-13 16:51:47 +0000
commit56e8fcdff473f8abc9bc773db371711bb949d5e0 (patch)
treea018ecf3c11d3e23b8e321b65f806742852b9c1b /meson.build
parenta858b8b3db7b0a9e068d1fca106c7e5fe0e9713f (diff)
downloadgcr-56e8fcdff473f8abc9bc773db371711bb949d5e0.tar.gz
build: Bump minimal GLib version to 2.44
GLib 2.44 adds `G_DEFINE_AUTOPTR_CLEANUP_FUNC` and `G_DECLARE_FINAL_TYPE` which we can use to cleanup the codebase and to let others use our types with `g_autoptr()`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7a91ac7..96bf0f4 100644
--- a/meson.build
+++ b/meson.build
@@ -33,7 +33,7 @@ libexecbindir = gcr_prefix / get_option('libexecdir') / meson.project_name()
podir = source_root / 'po'
# Dependencies
-min_glib_version = '2.38'
+min_glib_version = '2.44'
glib_dep = dependency('glib-2.0', version: '>=' + min_glib_version)
gmodule_dep = dependency('gmodule-no-export-2.0', version: '>=' + min_glib_version)
gthread_dep = dependency('gthread-2.0', version: '>=' + min_glib_version)