summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2022-08-07 23:00:18 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2022-09-04 12:50:58 +0000
commit3f36be1fd09e90d7b472cee24f5b4cb9eb12b76b (patch)
tree4b6d6572cc918b96c5481d4951daa00b4b4783cb /meson.build
parent4ec1071ea3070bdc85fd1c1cfe61af2349a8b39c (diff)
downloadgcr-3f36be1fd09e90d7b472cee24f5b4cb9eb12b76b.tar.gz
Drop gcr-gtk3 and gcr-gtk4
gcr historically consisted of 2 high-level parts: `gcr-base` and `gcr-ui`. `gcr-base` contains the core classes and interfaces to deal with crypto-related items (e.g. `GcrCertificate`), while `gcr-ui` contained GTK widgets to show those items (e.g. `GcrCertificateWidget`). Now: with the move to gcr4, it's becoming more and more clear to that this isn't really a path forward: On one hand, GTK4 has transitioned from a platform toolkit (usually GNOME was the primary target) to one that allows you to build your platform on top (e.g. libadwaita, libgranite, or your very own). Kepeing that in mind, having "GTK-based" widgets for use in general purpose doesn't really make sense, since it will always look out touch on platforms On the other hand, widgets are usually more faster-moving targets in both looks as well as API than an actual library, so in practice gcr-ui has a different lifecycle than gcr-base. Finally, @tintou has been doing an awesome effort to implement an API that allows consumers to write their own widgets, without having to deal with asn1 decoding etc. At this point, I think the certificate widget is likely the only widget we're seeing interest in. As such, this commit drops gcr-gtk3 and gcr-gtk4 as libraries. There's still a gcr-viewer debugging tool as a troubleshooting/debugging tool, that's it. See https://gitlab.gnome.org/GNOME/gcr/-/issues/100 for the related discussion.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 0 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index f66d0cc..3210f8d 100644
--- a/meson.build
+++ b/meson.build
@@ -37,8 +37,6 @@ podir = source_root / 'po'
gck_basename = 'gck-@0@'.format(gck_api_version)
gcr_base_basename = 'gcr-base-@0@'.format(gcr_api_version)
gcr_basename = 'gcr-@0@'.format(gcr_api_version)
-gcr_gtk3_basename = 'gcr-@0@-gtk3'.format(gcr_api_version)
-gcr_gtk4_basename = 'gcr-@0@-gtk4'.format(gcr_api_version)
# Dependencies
min_glib_version = '2.68'
@@ -76,11 +74,6 @@ if libsystemd.found() and systemd.found()
with_systemd = true
endif
-if get_option('gtk3')
- gtk3_min_version = '3.22'
- gtk3_dep = dependency('gtk+-3.0', version: '>=' + gtk3_min_version)
-endif
-
if get_option('gtk4')
gtk4_dep = dependency('gtk4')
endif
@@ -117,12 +110,6 @@ subdir('po')
subdir('egg')
subdir('gck')
subdir('gcr')
-if get_option('gtk3')
- subdir('gcr-gtk3')
-endif
-if get_option('gtk4')
- subdir('gcr-gtk4')
-endif
subdir('tools')
if get_option('gtk_doc')
if not get_option('introspection')