summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@src.gnome.org>2020-09-26 11:34:34 +0200
committerDaiki Ueno <dueno@src.gnome.org>2021-03-27 09:49:47 +0100
commit0932602d1af98c35bd2030629c517c173b480381 (patch)
tree00b954c5c70524f4230c088216d648b8524acb5c /meson.build
parent9761517998b59d684f03a14911de9fb3c8d67c76 (diff)
downloadgcr-0932602d1af98c35bd2030629c517c173b480381.tar.gz
gcr-ssh-agent: Port from gnome-keyring
This port the ssh-agent support provided as a sub-daemon in gnome-keyring, as a standalone binary, so that it can easily be managed through systemd.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fdad71c..3456d32 100644
--- a/meson.build
+++ b/meson.build
@@ -51,6 +51,9 @@ p11_system_config_modules = p11kit_dep.get_pkgconfig_variable('p11_system_config
if p11_system_config_modules == ''
error('Couldn\'t find location for pkcs11 module config')
endif
+libsecret_dep = dependency('libsecret-1', version: '>= 0.20', required: get_option('ssh_agent'))
+ssh_add_path = find_program('ssh-add', required: get_option('ssh_agent')).path()
+ssh_agent_path = find_program('ssh-agent', required: get_option('ssh_agent')).path()
if get_option('gtk')
gtk_min_version = '3.22'
@@ -69,6 +72,8 @@ conf.set('HAVE_TIMEGM', cc.has_function('timegm'))
conf.set('HAVE_MLOCK', cc.has_function('mlock'))
conf.set_quoted('GPG_EXECUTABLE', gpg_path)
conf.set_quoted('LIBGCRYPT_VERSION', libgcrypt_dep.version())
+conf.set_quoted('SSH_ADD_EXECUTABLE', ssh_add_path)
+conf.set_quoted('SSH_AGENT_EXECUTABLE', ssh_agent_path)
config_file = configure_file(
output: 'config.h',
configuration: conf,