summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw@src.gnome.org>2020-02-02 18:02:32 +0800
committerNiels De Graef <nielsdegraef@gmail.com>2020-02-03 10:31:33 +0000
commit06d7d43adba0d40e2821d1d1b08608ffec127471 (patch)
tree97c1515259eb7104594eea055a5b6384435a85af /meson.build
parent8b8e5b174087a90ea9ce8a302ba7e95ded6de3db (diff)
downloadgcr-06d7d43adba0d40e2821d1d1b08608ffec127471.tar.gz
meson: Fix LIBEXECDIR definition
After switching the build system from autotools to meson, gnome-keyring can no longer unlock ssh keys. sign_and_send_pubkey: signing failed: agent refused operation user@host's password: Running 'truss' on 'gnome-keyring-daemon' shows that it fails to execute 'gcr-ssh-askpass' file. write(2,"ssh_askpass: exec(<prefix>/libexec/gcr/gcr-ssh-askpass): No such file or directory\n",105) ERR#9 'Bad file descriptor' To keep both autotools and meson builds working, change the definition in meson build to be the same as autotools build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 96bf0f4..da20c2b 100644
--- a/meson.build
+++ b/meson.build
@@ -29,7 +29,7 @@ build_root = meson.current_build_dir()
cc = meson.get_compiler('c')
gcr_prefix = get_option('prefix')
-libexecbindir = gcr_prefix / get_option('libexecdir') / meson.project_name()
+libexecbindir = gcr_prefix / get_option('libexecdir')
podir = source_root / 'po'
# Dependencies