summaryrefslogtreecommitdiff
path: root/gck/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-12-22 21:26:10 +0100
committerStef Walter <stefw@gnome.org>2012-12-22 23:31:36 +0100
commit41d96e69e8b56aa88e36e8bd176c51c5aa93caf9 (patch)
treef78639aeef07a56cf9913e9d921f141957ecf351 /gck/Makefile.am
parent86550b678407e360515878703e81258044d84541 (diff)
downloadgcr-41d96e69e8b56aa88e36e8bd176c51c5aa93caf9.tar.gz
Separate the base and ui parts of the Gcr library more thoroughly.
* This is due to gobject introspection not being able to have separate GIRs provide the same namespace, and the desire to conditionally build the GTK+ dependent stuff. * Partially based on a patch by Mathias Hasselmann * Separate GIRs: Gcr and GcrUi * Separate libraries: libgcr-base-3.so and libgcr-ui-3.so. The latter links to the former. * Symlink libgcr-3.so to libgcr-ui-3.so * Expose internal symbols in libgcr-base-3.so so they can be easily shared by libgcr-ui-3.so * Add --without-gtk argument https://bugzilla.gnome.org/show_bug.cgi?id=688678
Diffstat (limited to 'gck/Makefile.am')
-rw-r--r--gck/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/gck/Makefile.am b/gck/Makefile.am
index 2319bf7..771a443 100644
--- a/gck/Makefile.am
+++ b/gck/Makefile.am
@@ -1,3 +1,4 @@
+include $(top_srcdir)/Makefile.decl
SUBDIRS = . tests
@@ -93,11 +94,11 @@ gck-marshal.c: gck-marshal.list $(GLIB_GENMARSHAL)
echo "#include \"gck-marshal.h\"" > $@ && \
$(GLIB_GENMARSHAL) $< --body --prefix=_gck_marshal >> $@
-gck-enum-types.h: gck-enum-types.h.template $(HEADER_FILES)
- $(AM_V_GEN) $(GLIB_MKENUMS) --template $^ > $@
+gck-enum-types.h: $(ENUM_TEMPLATE_H) $(HEADER_FILES)
+ $(GLIB_MKENUMS) --template $^ > $@
-gck-enum-types.c: gck-enum-types.c.template $(HEADER_FILES)
- $(AM_V_GEN) $(GLIB_MKENUMS) --template $^ > $@
+gck-enum-types.c: $(ENUM_TEMPLATE_C) $(HEADER_FILES)
+ $(GLIB_MKENUMS) --template $^ > $@
# ------------------------------------------------------------------
# INTROSPECTION
@@ -130,7 +131,6 @@ endif
# ----------------------------------------------------------------
-pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gck-$(GCK_MAJOR).pc
gck-$(GCK_MAJOR).pc: gck.pc
@@ -156,8 +156,6 @@ EXTRA_DIST = \
gck.pc.in \
gck-marshal.list \
gck.symbols \
- gck-enum-types.h.template \
- gck-enum-types.c.template \
pkcs11-trust-assertions.h \
pkcs11i.h