summaryrefslogtreecommitdiff
path: root/jpegutils/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-06-29 18:05:02 +0200
committerFelix Riemann <friemann@gnome.org>2017-11-12 13:58:45 +0100
commitb55f66560e6eff902b08346198ceb15b5500aed3 (patch)
treeead4c7f2ec4d8166fe04af40903b20ae77d0159f /jpegutils/meson.build
parent9fe34b11eedbec4a294168a6a4936cf66702bef0 (diff)
downloadeog-b55f66560e6eff902b08346198ceb15b5500aed3.tar.gz
build: Port to meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. https://bugzilla.gnome.org/show_bug.cgi?id=784354
Diffstat (limited to 'jpegutils/meson.build')
-rw-r--r--jpegutils/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/jpegutils/meson.build b/jpegutils/meson.build
new file mode 100644
index 00000000..87f65ab0
--- /dev/null
+++ b/jpegutils/meson.build
@@ -0,0 +1,16 @@
+if have_jpeg_80
+ sources = files('transupp-8a.c')
+else
+ sources = files('transupp-6b.c')
+endif
+
+libjpegutils = static_library(
+ 'eog-jpegutils',
+ sources: sources,
+ include_directories: top_inc
+)
+
+jpeg_deps += declare_dependency(
+ link_with: libjpegutils,
+ include_directories: include_directories('.')
+)