summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPlamena Manolova <plamena.n.manolova@intel.com>2013-02-22 14:56:05 +0000
committerNeil Roberts <neil@linux.intel.com>2013-03-19 17:34:46 +0000
commitdfb94cf4b0b6b42d6465df362a0c0af780596890 (patch)
treed82d28b3f9e146808fab5e94afe5ac0b4d3b15a3 /Makefile.am
parent576c7b55aa835448c977f1d79d128dffd40e7cd8 (diff)
downloadcogl-dfb94cf4b0b6b42d6465df362a0c0af780596890.tar.gz
Include CoglGst
CoglGst is a GStreamer integration library that facilitates video playback using the Cogl API. It works by retrieving each video frame from the GStreamer pipeline and attaching it to a Cogl pipeline in the form of a Cogl texture along with possible color model conversion shaders. The pipeline is then retrieved by the user during each draw. An example use of the CoglGst API is included in the examples directory. Reviewed-by: Neil Roberts <neil@linux.intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c764b468..15fb5899 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,6 +8,10 @@ if BUILD_COGL_GLES2
SUBDIRS += cogl-gles2
endif
+if BUILD_COGL_GST
+SUBDIRS += cogl-gst
+endif
+
SUBDIRS += examples doc po build
ACLOCAL_AMFLAGS = -I build/autotools ${ACLOCAL_FLAGS}
@@ -32,6 +36,7 @@ DISTCHECK_CONFIGURE_FLAGS = \
--enable-xlib-egl-platform \
--enable-wayland-egl-platform \
--enable-glx \
- --enable-wayland-egl-server
+ --enable-wayland-egl-server \
+ --enable-cogl-gst
include $(top_srcdir)/build/autotools/Makefile.am.release