summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2009-04-28 02:44:36 +0100
committerDamien Lespiau <damien.lespiau@intel.com>2009-04-28 02:48:19 +0100
commite89328b8af2e9edf518961ea6ead3d367f6695c5 (patch)
treeb664b2fcdd453157a58ad1da1808626f214050bd /scripts/Makefile.am
parentfd859199bd1d6421a56b27c1eef02a40696e1c44 (diff)
downloadclutter-gst-e89328b8af2e9edf518961ea6ead3d367f6695c5.tar.gz
[videosink] Add a I420 to RGBA fragment program
Things are a bit convoluted: * we want to keep GLSL shaders (eg OpenGL ES 2.0 does not have the GL_ARB_fragment_program extension) * we want to default to assembly fragment programs as they will support as broader range of hardware Now, those fragment programs are written in Cg, compiled with the Cg compiler and its arbfp1 profile and then turned into a header file thanks to a small python script. Sounds fun isn't it? As people may not want to install the Cg compiler, let's commit the actual fragment program. The configure script will detect if you have cgc and add targets to build the pso file accordingly.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
new file mode 100644
index 0000000..0648085
--- /dev/null
+++ b/scripts/Makefile.am
@@ -0,0 +1 @@
+EXTRA_DIST = pso2h.py