summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index aaf60644e..1c3cb936a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,17 +29,19 @@ endif
theme_in_files = index.theme.in
theme_DATA = $(theme_in_files:.theme.in=.theme)
-THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable/legacy,scalable/ui,scalable-up-to-32/status,")
+THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "symbolic/actions,symbolic/apps,symbolic/categories,symbolic/devices,symbolic/emblems,symbolic/emotes,symbolic/mimetypes,symbolic/places,symbolic/status,symbolic/legacy,symbolic/ui,scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable/legacy,scalable/ui,symbolic-up-to-32/status,")
%.theme: %.theme.in $(SVGOUTDIR) Makefile
dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/Adwaita/##g'`"; \
sed -e "s|\@THEME_DIRS\@|$$dirs|g" < $< > $@; \
for dir in `echo $$dirs | sed -e "s/,/ /g"`; do \
sizefull="`dirname $$dir`"; \
- if test "$$sizefull" = "scalable"; then \
+ if test "$$sizefull" = "symbolic"; then \
size="16"; \
- elif test "$$sizefull" = "scalable-up-to-32"; then \
+ elif test "$$sizefull" = "symbolic-up-to-32"; then \
size="16"; \
+ elif test "$$sizefull" = "scalable"; then \
+ size="128"; \
else \
size="`echo $$sizefull | sed -e 's/x.*$$//g'`"; \
fi; \
@@ -89,10 +91,14 @@ THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in
echo "MinSize=8" >> $@; \
echo "MaxSize=512" >> $@; \
echo "Type=Scalable" >> $@; \
- elif test "$$sizefull" = "scalable-up-to-32"; then \
+ elif test "$$sizefull" = "symbolic-up-to-32"; then \
echo "MinSize=16" >> $@; \
echo "MaxSize=32" >> $@; \
echo "Type=Scalable" >> $@; \
+ elif test "$$sizefull" = "symbolic"; then \
+ echo "MinSize=8" >> $@; \
+ echo "MaxSize=512" >> $@; \
+ echo "Type=Scalable" >> $@; \
elif test "$$size" = "256"; then \
echo "MinSize=56" >> $@; \
echo "MaxSize=256" >> $@; \