summaryrefslogtreecommitdiff
path: root/themes/Adwaita/gtk-2.0/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'themes/Adwaita/gtk-2.0/Makefile.am')
-rw-r--r--themes/Adwaita/gtk-2.0/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/themes/Adwaita/gtk-2.0/Makefile.am b/themes/Adwaita/gtk-2.0/Makefile.am
index 0e77b5df..6542cf61 100644
--- a/themes/Adwaita/gtk-2.0/Makefile.am
+++ b/themes/Adwaita/gtk-2.0/Makefile.am
@@ -7,7 +7,9 @@ libadwaita_la_LDFLAGS = -module -avoid-version -no-undefined
libadwaita_la_LIBADD = $(GTK2_ENGINE_LIBS)
themedir = $(datadir)/themes/Adwaita/gtk-2.0
-theme_data = gtkrc main.rc apps.rc
+theme_data = gtkrc \
+ main.rc \
+ apps.rc
asset_dirs = "assets"
@@ -181,6 +183,8 @@ asset_data = \
assets/treeview-separator-ltr.png \
assets/treeview-separator-rtl.png
+
+
install-data-local:
for dir in $(asset_dirs); do \
for file in `cd $(srcdir)/$$dir && find . -maxdepth 1 \( -name "*.png" \)`; do \
@@ -188,6 +192,7 @@ install-data-local:
$(install_sh_DATA) $(srcdir)/$$dir/$$file $(DESTDIR)$(themedir)/$$dir/$$file; \
done; \
done
+# FIXME: this is probably awful $(install_sh_DATA) $(srcdir)/$(theme_data) $(DESTDIR)$(themedir)/;
uninstall-local:
for dir in $(asset_dirs); do \